Mysql2 (Ruby gem)

参考:

brianmario/mysql2: A modern, simple and very fast Mysql library for Ruby – binding to libmysql – GitHub

mysql2 | RubyGems.org

cannot find -lmariadb エラー

CentOS で mysql2 gem をインストールする際に MariaDB のライブラリが見つからない旨のエラーが発生する。

対処法:

MariaDB-shared をインストールする。

$ yum install MariaDB-shared

参考:

CentOS7 + MariaDB10 で gem mysql2 がエラーになる – Qiita

タグ:

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です