Babel 7 を使う方法

参考:

webpack4でSCSS+Autoprefixer+CSScomb+Babel+ESLint環境構築 | iwb.jp

webpack4を触ってみる | よしかわーるど

Webpack4とBabel7とnode-sassによるWebページ作成環境を構築する | 測度ゼロの抹茶チョコ

preset-env

参考:

@babel/preset-env | Babel [Official]

スプレッド演算子

参考:

@babel/plugin-proposal-object-rest-spread | Babel [Official]

babel/packages/babel-plugin-proposal-object-rest-spread at master · babel/babel – GitHub

Using babel 7 with env preset: object spread causes error about missing objectRestSpread parser plugin · Issue #6970 · babel/babel – GitHub

Webpacker v4.0.0.pre

参考:

webpacker/babel.js at v4.0.0.pre.3 · rails/webpacker – GitHub

バージョンの不一致

参考:

Error: Requires Babel “^7.0.0-0”, but was loaded with “6.26.3” · Issue #522 · FormidableLabs/spectacle – GitHub

タグ:

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です